Smartparts on SharePoint 2010

Mar 29, 2010 at 5:54 PM

Hello, 

I'm trying to find out if web parts built for Smartpart can be migrated to SharePoint 2010 and if so, what's the procedure?  Does anyone have an idea?

Thank you

May 18, 2010 at 12:32 PM

Hi, I am also interested in the answer.  Does Sharepoint 2010 have a built in mechanism to parse user controls

Regards

Jaco

May 19, 2010 at 2:33 PM

Hay,

Good question, i'd like to know the answer too..

I've read about the Visual webparts with VS 2010 but our environment has a lot of smartparts in like 100's of subsites.. How can I handle that?

Thanks in advance!

Jul 1, 2010 at 11:28 AM

It's working in 2010. You can't use installer but you can use stsadm -o addsolution and then deploy it via central administration

Jul 5, 2010 at 11:02 AM

Thanks alot for your answer.

Aug 10, 2010 at 10:08 PM

I have upgraded the SmartPart code to 2010. I am working a few issues out, but it seems to work fine. I prefer smart parts because I can develop Webparts with out referencing SharePoint. This way I can work out side a server enviornment. I would like to post the solution to this site.

 

Nick

Aug 11, 2010 at 6:05 PM

It fully works, how can I upload the source?

Aug 17, 2010 at 5:53 PM
Hello, Is this an upgrade to the ReturnOfSmartPart v1.3? I hope they let you upload it soon. I am not a developer and it's deployed to my SP2007 farm. Really need a SP2010 compatible version to connect DB's to SP2010 farm. Bob
Aug 17, 2010 at 5:58 PM

Yes it is an upgrade. I have solution which you can deploy the SmartPart (WebPart) to SharePoint 2010 with Visual Studio 2010. It works 100%. I have not had time to fix or work on the installer. I have not herd back from Jan at all. Should I start another codeplex branch site?

Aug 17, 2010 at 6:50 PM
Nick, I believe you can start a new Project. If you need someone to test, i have a dev SP2010 farm at 4762.1000, that i would be happy to test for you. I could install then dump and load a DB from my SP2007 farm and see how it works. Bob
Aug 18, 2010 at 6:09 AM

Hi Nick,

I am willing to help (testing and development) if you need help

Regards

Jaco

Aug 18, 2010 at 10:06 PM

I will try and upload it tonight. To another codeplex project. 

Nick

Aug 31, 2010 at 9:27 PM

Sorry I have not done this yet, I have had a lot of drama as of late. Going to do it now.

Aug 31, 2010 at 10:00 PM

Done http://smartpart2010.codeplex.com/

May 17, 2011 at 1:38 PM

Do you have a version of either compiled or uncompiled code that is AJAX enabled?

May 17, 2011 at 2:14 PM

They both work with AJAX out of the box.

May 17, 2011 at 2:53 PM

Then why are there two versions of the 2007 Smart Part with one that says AJAX and one that doesn't?

May 17, 2011 at 3:27 PM

Its a web part it installs both and you decide which to use. POSTBACK or non POST BACK. 

Jun 14, 2011 at 7:07 PM

Can anyone please help? I need to know how I can install it on SharePoint 2010 server? I do not see wsp file in the package posted by nmccready. Thanks

Jun 14, 2011 at 7:29 PM

Go here and use visual Studio 2010 to Deploy or package your .wsp. It will then be in the \bin directory. If you need the .wsp file directly I can post it to the site. The below link is the implementation of smartparts to 2010.

http://smartpart2010.codeplex.com/

Jun 14, 2011 at 7:44 PM

Hello, I really appreciate if you can post .wsp file for this package. I will look forward to download .wsp file. Thank you very much a fast respone.

Jun 14, 2011 at 7:48 PM

Done go here http://smartpart2010.codeplex.com/releases/view/68318

Jun 14, 2011 at 7:49 PM

Remember the assembly Product key is different and it has different signature than the original. So you will need to update your SharePoint root config for allowing it !

Jun 14, 2011 at 8:01 PM

I really appreciate all your help. Thanks for putting togther wsp file.