Source Code

Feb 19, 2008 at 10:44 AM
Jan,

it would be great if we could get the source code of this web part. We will be using User Controls to implement web applications in SharePoint, and your tool is invaluable to us.

However, I would love to be able to customize certain parts of it, and although I've used the Reflector the get the source, I'd rather have the official source code than an unofficial hack of it.

Cheers
David
Coordinator
Feb 19, 2008 at 12:41 PM
I'll post the source files later this week!
Feb 19, 2008 at 1:25 PM
That's great!

Thanks
Feb 20, 2008 at 2:52 AM
Smartpart rocks. Since the v1.3 assembly name is same as v1.2, we have problem to have them run side by side.
Coordinator
Feb 20, 2008 at 7:25 AM
Can you explain which problem you have? The assembly gets deployed to the GAC so that shouldn't be an issue.

gzcodeplex wrote:
Smartpart rocks. Since the v1.3 assembly name is same as v1.2, we have problem to have them run side by side.

Feb 22, 2008 at 2:51 AM
Here is the error I got:

Error: unable to load ~\/UserControls\AJAXSampleProvider.ascx
Details: c:\Inetpub\wwwroot\wss\VirtualDirectories\xxxdev.us.bosch.com80\UserControls\AJAXSampleProvider.ascx.cs(13): error CS0433: The type 'SmartPart.IConnectionProviderControl' exists in both 'c:\WINDOWS\assembly\GACMSIL\ReturnOfSmartPart\1.3.0.0_9f4da00116c38ec5\ReturnOfSmartPart.dll' and 'c:\WINDOWS\assembly\GACMSIL\ReturnOfSmartPart\1.2.0.0_9f4da00116c38ec5\ReturnOfSmartPart.dll'


Coordinator
Feb 22, 2008 at 8:04 AM
Probably you still have a reference to the old assembly of the SmartPart in the web.config.


gzcodeplex wrote:
Here is the error I got:

Error: unable to load ~\/UserControls\AJAXSampleProvider.ascx
Details: c:\Inetpub\wwwroot\wss\VirtualDirectories\xxxdev.us.bosch.com80\UserControls\AJAXSampleProvider.ascx.cs(13): error CS0433: The type 'SmartPart.IConnectionProviderControl' exists in both 'c:\WINDOWS\assembly\GACMSIL\ReturnOfSmartPart\1.3.0.0_9f4da00116c38ec5\ReturnOfSmartPart.dll' and 'c:\WINDOWS\assembly\GACMSIL\ReturnOfSmartPart\1.2.0.0_9f4da00116c38ec5\ReturnOfSmartPart.dll'




Feb 26, 2008 at 3:34 AM
Yes. I have both assemblies in the web.config file, since I don't want to change the pages with old version and just want to use the 1.3 in the new pages. So I need both versions run side by side, do you think that is possbile? Thanks.
Feb 28, 2008 at 9:58 AM
Edited Feb 28, 2008 at 10:20 AM
Jan, would it be possible to post the Source Code please?

Edit: Or you can just post the code where the actual loading of the UserControls is loaded into the WebPart.
Coordinator
Feb 29, 2008 at 7:33 AM
I've uploaded the source, check the "Source Code" tab!
Feb 29, 2008 at 8:27 AM
Thanks very much Jan. Much appreciated!
Mar 5, 2008 at 2:50 AM
Thank you Jan. Is IAdvancedUserControl.cs missing? its size is 0.
Mar 5, 2008 at 1:40 PM
Yes, I've had this problem too.