Return of SmartPart 1.3 and .NET Framework 3.5 (Ajax)

Apr 16, 2008 at 12:56 PM
Edited Apr 16, 2008 at 1:07 PM
Hello,

We have configured our sharepoint site to run AJAX from the .NET Framework 3.5 libraries. Used in custom webparts this works fine. We have installed Return of Smartpart 1.3 and tried using the one with AJAX support, we then receive an error:

"The Web Part you attemped to add no longer exists in the Closed Web Parts Gallery. Refresh your brouwser to update the Web Part Page and the Gallery."

Exact configuration:
WSS 3.0 SP1
.NET Framework 3.5 installed
AJAX integrated in web.config of sharepoint site

-------------------------------------------------------------------
solved using this post:

http://www.codeplex.com/smartpart/WorkItem/View.aspx?WorkItemId=5929
Jan 30, 2010 at 5:04 PM

Hi markvanderpal,

how can i configure sharepoint for framework 3.5 i did every thing but finally give me "An  Unhandled Exception" in page that contains the smart web part

please any Help....

 

Feb 1, 2010 at 8:36 AM

Hi there,

The error you receive can be caused by an error in the code of the usercontrol, try to encapsulate it with a try catch to verify the usercontrol is alright.

Have you checked the eventlog?

rgds.

Feb 1, 2010 at 8:54 AM

 

Hi markvanderpal,

Thanks For Reply,

i forgot to mention that i use in that control Ajax Controls Toolkit (Tab Control) version 3.0.30512.1 and FrameeWork 3.5.

the Error Page is "An unexpected error has occurred."

Here the the last line of Log File

02/01/2010 10:46:20.41     mssearch.exe (0x0DBC)                       0x1A7C    Search Server Common              GatherStatus                      0    Monitorable    Unlock Queue, project Search - File:d:\office\source\search\search\gather\server\gatherobj.cxx Line:2922

i don't know what is wrong maybe about Ajax Toolkit.

 

Dec 8, 2010 at 10:01 PM

Hi, 

I use ReturnOfSmartPart 1.3. I tried to use a user control which contains another user control in it and get an error "The referenced file '/CtlTest1.ascx' is not allowed on this page". 

2 user controls I have. CtlTest1.ascx and CtlMain.ascx.

In CtlMain.ascx, I use CtlTest1.ascx control. Finally I want to load CtlMain.ascx in sharepoint using ReturnOfSmartPart. I get the error message "The referenced file '/CtlTest1.ascx' is not allowed on this page". Please advice me.

Thanks,

Naush