Unable to add selected Web Part

Jul 2, 2008 at 4:01 PM
I've had SmartPart successfully installed and working on WSS 3.0 for several months but a WSS crash forced me to reinstall WSS and reconfigure my web.config for Smart Part.  All of the SmartParts that were previously installed are working  but when I try and add a new one, I get a popup error message in IE saying 'Unable to add selected Web Part' and the error below is generated in the WSS logs.  To really add a twist to this, I am able to add new SmartParts from my PC at home and from my co-workers machine logged in under my name.  I don't understand why I would not be able to add a SmartPart from only 1 machine (all machines have IE 7).  Thanks 


07/02/2008 10:45:02.34  w3wp.exe (0x0AD4)                        0x0EE0 Windows SharePoint Services    Web Parts                      89ku High     Failed to add webpart http%253A%252F%252Ftclprodapp1%252F%255Fcatalogs%252Fwp%252FSmartPartv3AJAX%252Edwp;SmartPart%2520with%2520AJAX.  Exception System.ArgumentException: Value does not fall within the expected range.     at Microsoft.SharePoint.SPWeb.GetServerRelativeUrlFromUrl(String fullOrRelativeUrl, Boolean includeQueryString, Boolean canonicalizeUrl)     at Microsoft.SharePoint.SPWeb.GetServerRelativeUrlFromUrl(String fullOrRelativeUrl)     at Microsoft.SharePoint.SPWeb.GetFileAsString(String url)     at Microsoft.SharePoint.WebPartPages.WebPartQuickAdd.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)