Possible solution to cannot load abcdef.ascx issue

Feb 3, 2010 at 3:05 PM
Edited Feb 3, 2010 at 3:08 PM

I installed SmartPart on a SharePoint 2007 SP2 Enterprise virtual machine and ran into the issue where the User Control To Display drop down list box prefixes each otherwise eligible control with Cannot load ...

I tried restarting IIS which did NOT fix the issue.

Finally, I ran a special PowerShell script that deleted all files beneath c:\windows\Microsoft.Net\Framework\v2.0.50727\Temporary ASP.Net Files\ and then, more good measure, reset IIS again.

I then closed all of my browser sessions.

After that, I was able to use the sample HelloSmartPart.ascx in a regular SmartPart and I was able to use the sample AjaxHelloSmartPart.ascx in an AJAX SmartPart.

I hope this helps others struggling with the same issue.

For the record, my virtual machine is running:

Windows Server 2008 SP2 (32-bit) + all patches through February 2010

SQL Server 2008 Enterprise (32-bit) SP1 + post-SP1 Cumulative Update 7 (a.k.a., 10.0.2746.0)

SharePoint 2007 Enterprise (32-bit) SP2

Visual Studio Team System 2008 Development Edition SP1